using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)";
string substitution = @" ";
string input = @"0ABCD TECHNOLOGIES SERVICES
ABCD0 TECHNOLOGIES SERVICES
ABCD 0TECHNOLOGIES SERVICES
ABCD TECHNOLOGIES0 SERVICES
ABCD TECHNOLOGIES 0SERVICES
ABCD TECHNOLOGIES SERVICES0
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}