use strict;
my $str = '0ABCD TECHNOLOGIES SERVICES
ABCD0 TECHNOLOGIES SERVICES
ABCD 0TECHNOLOGIES SERVICES
ABCD TECHNOLOGIES0 SERVICES
ABCD TECHNOLOGIES 0SERVICES
ABCD TECHNOLOGIES SERVICES0
';
my $regex = qr/(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";