re = /(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)/m
str = '0ABCD TECHNOLOGIES SERVICES
ABCD0 TECHNOLOGIES SERVICES
ABCD 0TECHNOLOGIES SERVICES
ABCD TECHNOLOGIES0 SERVICES
ABCD TECHNOLOGIES 0SERVICES
ABCD TECHNOLOGIES SERVICES0
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result