use strict;
my $str = ' \'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_ID\'
\'is null and v.Block<>1\')
\'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')
';
my $regex = qr/(^\s+'.+)'(?:(?=' \+)\1|)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";