# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\W+//g;t' <<< " YES leading spaces are valid, problemsetters are evillllll"