package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\W+`)
var str = ` YES leading spaces are valid, problemsetters are evillllll`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}