import Foundation
let pattern = #"^\W+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" YES leading spaces are valid, problemsetters are evillllll"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)