# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\+62 ((\d{3}([ -]\d{3,})([- ]\d{4,})?)|(\d+)))|(\(\d+\) \d+)|\d{3}( \d+)+|(\d+[ -]\d+)|\d+"
test_str = ("+62 361 222777\n"
"+62 813-444-5555 \n"
"+62 812-3333-3333\n"
"+62 811 391 2103 \n"
"+62 361-2277777\n"
"(0361) 227337\n"
"+62 8113912103\n"
"08134455555\n"
"0361-2277777\n"
"+62 812 3333 3333\n"
"+62 877 80803550\n"
"081339222111\n"
"081 339 222 111\n"
"+62 811338429196")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.