re = /(\+62 ((\d{3}([ -]\d{3,})([- ]\d{4,})?)|(\d+)))|(\(\d+\) \d+)|\d{3}( \d+)+|(\d+[ -]\d+)|\d+/m
str = '+62 361 222777
+62 813-444-5555
+62 812-3333-3333
+62 811 391 2103
+62 361-2277777
(0361) 227337
+62 8113912103
08134455555
0361-2277777
+62 812 3333 3333
+62 877 80803550
081339222111
081 339 222 111
+62 811338429196'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end