const regex = /(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(![!>#]?(?:(?=[^\\s!>#$]|\\s{2}|\\s\\$)|\\$(?!\\S)))\\s*(.*)', 'gm')
const str = `Should not match:
! Hi
!! Hi
!> Hi
Needs to match, with ! !! !> being in a group:
!Hi
!!Hi
!>Hi
! Hi
!! Hi
!> Hi
! Hi
!! Hi
!> Hi
Ideally should not match:
!\$OMP
Ideally should Match:
! \$
!\$ OMP
!\$ Hi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}