use strict;
my $str = 'Should not match:
! Hi
!! Hi
!> Hi
Needs to match, with ! !! !> being in a group:
!Hi
!!Hi
!>Hi
! Hi
!! Hi
!> Hi
! Hi
!! Hi
!> Hi
Ideally should not match:
!$OMP
Ideally should Match:
! $
!$ OMP
!$ Hi';
my $regex = qr/(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}