re = /(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)/m
str = 'Should not match:
! Hi
!! Hi
!> Hi
Needs to match, with ! !! !> being in a group:
!Hi
!!Hi
!>Hi
! Hi
!! Hi
!> Hi
! Hi
!! Hi
!> Hi
Ideally should not match:
!$OMP
Ideally should Match:
! $
!$ OMP
!$ Hi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end