// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^*]*(?:\*{2}[^ ][^*]*[^ ]\*{2}[^*\n]*)*(?:\*{2}(?: [^*]+|[^*]+ )\*{2}).*$").unwrap();
let string = "**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.
Absolutely no bold tagging in this sentence.
**correct** This line is **correct** and **properly marked down**.
But this line **is not** because ** the second bold is wrong**.
** Also** **This Also** ** This Also ** this line is wrong **even though this is right **.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}