$re = '/<[^>]*>/m';
$str = '<a title="1 < 3, but 3 > 2">Don\'t use regex to parse HTML</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);