import re
regex = re.compile(r"(?=\()(?:(?=.*?\((?!.*?\1)(.*\)(?!.*\2).*))(?=.*?\)(?!.*?\2)(.*)).)+?.*?(?=\1)[^(]*(?=\2$)", flags=re.DOTALL)
test_str = ("Answer ((((((((((misery)))))))))) adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.\n\n"
"Answer misery adieus add wooded how nay men before though. Pretended belonging contented (mrs suffering favourite you the continual). Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see) day promotion. Quitting) informed concerns) can men now. Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome (((admitted. \n\n"
"Answer misery))) adieus add wooded how nay men before though. Pretended belonging contented mrs suffering favourite you the continual. Mrs civil nay least means tried drift. (Natural) (end) (law) whether but and towards certain. (Furnished (unfeeling his sometimes (see day promotion. Quitting) informed concerns) can men now). Projection to or up conviction uncommonly delightful continuing. In appetite ecstatic opinions hastened by handsome admitted.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")