$re = '/((.*?)(\;))(.*?)/m';
$str = 'C:\\ProgramData\\Anaconda3;C:\\ProgramData\\Anaconda3\\Library\\mingw-w64\\bin;C:\\ProgramData\\Anaconda3\\Library\\usr\\bin;C:\\ProgramData\\Anaconda3\\Library\\bin;C:\\ProgramData\\Anaconda3\\Scripts;C:\\ProgramData\\Anaconda3\\bin;C:\\ProgramData\\Anaconda3\\condabin;C:\\Program Files (x86)\\Common Files\\Oracle\\Java\\javapath;C:\\Program Files\\CMake\\bin;C:\\MinGW\\bin;C:\\Program Files (x86)\\Microsoft Visual Studio\\2019\\Community\\VC\\Tools\\MSVC\\14.26.28801\\bin\\Hostx64\\x64;C:\\Users\\romeda\\AppData\\Roaming\\Python\\Python37\\Scripts;C:\\Program Files (x86)\\Common Files\\Intel\\Shared Libraries\\redist\\intel64_win\\compiler;C:\\Program Files\\Java\\jdk1.8.0_241\\bin;C:\\Oracle\\instantclient_19_6;C:\\Oracle\\product\\12.1.0\\client_2;C:\\ProgramData\\Anaconda3;C:\\ProgramData\\Anaconda3\\Scripts;C:\\ProgramData\\Anaconda3\\pkgs\\conda-4.5.4-py36_0\\Scripts;C:\\ProgramData\\Anaconda3\\Library\\bin;C:\\Program Files (x86)\\Graphviz2.38\\bin;C:\\Program Files\\NVIDIA GPU Computing Toolkit\\CUDA\\v10.1\\bin;C:\\Program Files\\NVIDIA GPU Computing Toolkit\\CUDA\\v10.1\\libnvvp;C:\\Program Files\\NVIDIA Corporation\\NVSMI;C:\\Program Files\\NVIDIA Corporation\\Nsight Compute 2019.4.0;C:\\Program Files (x86)\\NVIDIA Corporation\\PhysX\\Common;C:\\ProgramData\\Oracle\\Java\\javapath;C:\\WINDOWS\\system32\\config\\systemprofile\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Program Files (x86)\\Adaptiva\\AdaptivaClient\\bin\\x32;C:\\Program Files (x86)\\Adaptiva\\AdaptivaClient\\bin\\x64;C:\\Program Files (x86)\\Webex\\Webex\\Applications;C:\\Program Files\\PuTTY;C:\\Program Files\\Git\\cmd;C:\\Program Files\\MongoDB\\Server\\4.2\\bin;C:\\Program Files\\FlexNet;C:\\ProgramData\\Anaconda3\\envs\\gis\\orca_app;C:\\WINDOWS\\system32;C:\\WINDOWS;C:\\WINDOWS\\System32\\Wbem;C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0;C:\\WINDOWS\\System32\\OpenSSH;C:\\Users\\romeda\\MiKTeX 2.9\\miktex\\bin\\x64;C:\\Users\\romeda\\batchfiles;C:\\Program Files\\Amazon\\AWSSAMCLI\\bin;C:\\Users\\romeda\\AppData\\Local\\Programs\\ArcGIS\\Pro\\bin;C:\\OSGeo4W64\\bin;C:\\OSGeo4W64\\bin\\gdalplugins;c:\\spark\\bin;C:\\Program Files (x86)\\Java\\jdk1.8.0_202\\bin;C:\\Users\\romeda\\MiKTeX\\miktex\\bin\\x64;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Amazon\\AWSCLIV2;C:\\Users\\romeda\\partiql-cli\\bin;C:\\Program Files (x86)\\FME;C:\\Program Files\\FME;C:\\MinGW\\bin;C:\\Users\\romeda\\MiKTeX\\miktex\\bin\\x64;C:\\Program Files (x86)\\Graphviz2.38\\bin;C:\\Users\\romeda\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Users\\romeda\\AppData\\Local\\atom\\bin;C:\\Users\\romeda\\AppData\\Local\\GitHubDesktop\\bin;C:\\Users\\romeda\\AppData\\Local\\Microsoft\\WindowsApps;C:\\Program Files\\JetBrains\\PyCharm 2020.1.1\\bin;.;C:\\Program Files (x86)\\GitHub CLI;.;C:\\Users\\romeda\\AppData\\Local\\Programs\\Microsoft VS Code\\bin';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;