use strict;
my $str = '<[{]..[7]..[]..[]..[C2I43].
<[(_#/}$)$]..[GO5A]..[G5]..[3W4].
<[^]..[54]..[S].
<[@].
<[)$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].
Traincode!';
my $regex = qr/(?<train>((<\[[^a-zA-Z0-9]*\]\.){1})((\.\[[a-zA-Z0-9]*\]\.))*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}