#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-9]{4}-[0-9]{2}-[0-9]{2,}|[\d]{0,}|[NnaAOoEe]{0,})(.*)"
Local $sString = "2020-10-2125Chavez and Sons" & @CRLF & _
"2020-05-02Bean Inc" & @CRLF & _
"NaNRobinson, Mcmahon and Atkins" & @CRLF & _
"2020-04-25Hill-Fisher" & @CRLF & _
"2020-04-02Nothing and Sons" & @CRLF & _
"52457Carpenter and Sons" & @CRLF & _
"0Carpenter and Sons" & @CRLF & _
"Carpenter and Sons" & @CRLF & _
"NoneEconomy and Sons" & @CRLF & _
"2020-04-02" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")