import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d+) )(.+)";
final String string = "30304 Homer Simpson1\n"
+ "30305 Homer Simpson2\n"
+ "30306 Homer Simpson3\n"
+ "30307 Homer J Simpson4\n"
+ "30308 Homer Simpson5\n"
+ "30309 Homer Simpson6\n"
+ "30310 Homer Pete Simpson7\n"
+ "30311 Homer Simpson8\n"
+ "30312 Homer Simpson9\n"
+ "30313 Homer Simpson10\n"
+ "30314 Homer Simpson11\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}