import Foundation
let pattern = #"(?s)^.{0,1000}DELETE ME(?-s).*\R?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)