package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]?+(,\d{3})*\.[0-9]{2}$`)
var str = `.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}