# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\{\d+}//gm;t' <<< "{12313}Luglio
{34}Maggio"