$re = '/^\{\d+}/m';
$str = '{12313}Luglio
{34}Maggio';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;