#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))"
Local $sString = "10,10 + 9, 9" & @CRLF & _
"10,1,0+9,9" & @CRLF & _
"10,10,+,9,9" & @CRLF & _
"10,10+9,9" & @CRLF & _
"10+9,0" & @CRLF & _
"10,0+9" & @CRLF & _
"10+9" & @CRLF & _
"10,0+9,4" & @CRLF & _
"10,2+3" & @CRLF & _
"" & @CRLF & _
",?(\d+)?|(\+|-|\*|\/|\,|)" & @CRLF & _
"(\+|\-|\*|\/)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")