import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z,]\\d+((\\,\\d+(\\+|\\-|\\*|\\/)\\d+(\\,\\d+|))|((\\+|\\-|\\*|\\/)(\\d+(\\,\\d+|))))";
final String string = "10,10 + 9, 9\n"
+ "10,1,0+9,9\n"
+ "10,10,+,9,9\n"
+ "10,10+9,9\n"
+ "10+9,0\n"
+ "10,0+9\n"
+ "10+9\n"
+ "10,0+9,4\n"
+ "10,2+3\n\n"
+ ",?(\\d+)?|(\\+|-|\\*|\\/|\\,|)\n"
+ "(\\+|\\-|\\*|\\/)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}