Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))
/
g
Input 1
1
New
10,10 + 9, 9 10,1,0+9,9 10,10,+,9,9 10,10+9,9 10+9,0 10,0+9 10+9 10,0+9,4 10,2+3 ,?(\d+)?|(\+|-|\*|\/|\,|) (\+|\-|\*|\/)