$re = '/^[23]\.[0-9]\.(1[0-9]|[0-9])$/m';
$str = '2.3.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);