import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{3}\\s)([A-Za-z\\.]*)\\s([A-Za-z\\.]*)";
final String string = "009 G Nantpaipakdee 38 955 722 650-240-0111\n"
+ "002 Eugénie Romette 432 734 782\n"
+ "005 Christina Pandullo 410-527-8241 410-527-8158\n"
+ "020 Joe Smith 410-771-7815 410-527-8771\n"
+ "030 K Kordysiewicz 42 239 3875\n"
+ "300 Cecile A. Wattiez 432 736 683\n"
+ "305 Do not use";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}