# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\?]?([\w]+)=([\w-]+)/$1=$2/mg;t' <<< "/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes"