package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\?]?([\w]+)=([\w-]+)`)
var str = `/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes`
var substitution = "$1=$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}