import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\?]?([\\w]+)=([\\w-]+)";
final String string = "/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing\n"
+ "/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes";
final String subst = "$1=$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}