import Foundation
let pattern = #"\b(?<!(SUPER|POWER)\s)(?<!(SHOP|XTRA|TOWN|PICK)\s)(?<!(BIG|TOP|MAX)\s)(?<!NU\s)(?<!U\s)SAVE\s?(SUPERMARKET|HYPER)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"BIG SAVE SUPERMARKET HERE and SAVE HYPER"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)