use strict;
my $str = 'wsrep_provider_options=\'gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem\'
wsrep_provider_options=\'gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem; gcache.size=4G\'
wsrep_provider_options=\'gcache.size=4G; gmcast.segment=0; ist.recv_addr=tcp://db7; ist.recv_bind=tcp://0.0.0.0; socket.ssl_cert=/etc/mysql/wsrep/ssl/gmnode.pem; socket.ssl_key=/etc/mysql/wsrep/ssl/gmnode.key; socket.ssl_ca=/etc/mysql/wsrep/ssl/gmca.pem\'';
my $regex = qr/^(wsrep_provider_options(?!.*\bgcache.size\b).*)('$)/mp;
my $subst = '\\1; gcache.size=4G\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";