# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{([^#|T|(])/{'{'}$1/gm;t' <<< "{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]
{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}
"