using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{([^#|T|(])";
string substitution = @"{'{'}$1";
string input = @"{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]
{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}