re = /\|Transition Reason:(?<Transiction_Reason>[^\|]*)\|/m
str = 'Data1: |Transitioned to:Team1|Transition Reason:Out of Scope|handledbySomeone3|
Data2: |Transitioned to:Team2|Transition Reason:Invalid Description|handledbySomeone2|
Data3: |Transitioned to:Team3|Transition Reason:Incomplete Details|handledbySomeone1|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end