use strict;
my $str = '<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute="value" attribute= "value"></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute="value" attribute="val\\"ue" attribute=\'val\\\'ue\'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute ="value" attribute></tag>';
my $regex = qr/(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\])*?)")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}