use strict;
my $str = '#1234 10% activity@timing:information and other activity2@timing:adws
#3132 10% testing@1.10:test message frontend@44min:other comments
#3132 10% testing@1.10:test message
#3132 10% testing@1.10
';
my $regex = qr~(?<!\S)(\w+)@([\w.]*)\:?(\w+(?:\h\w+)*)(?!\S)~up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}