#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PASSWORD\(\:\)"
Local $sString = "# Match this, is exact" & @CRLF & _
"PASSWORD(:)" & @CRLF & _
"" & @CRLF & _
"#Not same case (lowercase vs uppercase)" & @CRLF & _
"Password(:)" & @CRLF & _
"" & @CRLF & _
"#No semi-colon" & @CRLF & _
"PASSWORD()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")