import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "intervals \\[\\d+\\]:\\s+\\Kxmin = (?P<xmin>\\d+(\\.\\d+)?) \\\n"
+ " \\s+xmax = (?P<xmax>\\d+(\\.\\d+)?)\\s+text = \"(?P<text>[^\"]*)\"";
final String string = "intervals [1]:\n"
+ " xmin = 0 \n"
+ " xmax = 13.139997023062838 \n"
+ " text = \"\" \n"
+ " intervals [2]:\n"
+ " xmin = 13.139997023062838 \n"
+ " xmax = 14.763036269953904 \n"
+ " text = \"Cities are like siblings in a large polygamous family.\" \n"
+ " intervals [3]:\n"
+ " xmin = 14.763036269953904 \n"
+ " xmax = 17.01 \n"
+ " text = \"\" \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}