import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:(?:[2-9]|[1-2]\\d|[3][0-5])\\^\\^(?:\\w*\\.\\w+|\\w+(?:\\.(?!\\.))\\w*|\\w+))|(?:\\d*\\.\\d+|\\d+(?:\\.(?!\\.))\\d*|\\d+))(?:(?:``(?:\\+|-)?(?:\\d*\\.\\d+|\\d+\\.\\d*|\\d+))|(?:`(?:(?:\\+|-)?(?:\\d*\\.\\d+|\\d+\\.\\d*|\\d+))?))?(?:\\*\\^(?:\\+|-)?\\d+)?";
final String string = "// Correct Numbers\n"
+ "2^^101.101\n"
+ "35^^WolframLanguage\n"
+ "16^^dead.Beef\n"
+ "123`\n"
+ "1.381`\n"
+ "16^^9fe.c3`7\n"
+ "3.0`+7\n"
+ "3`7\n"
+ "3.000000000000000000000`7\n"
+ "3.000000000000000000`-7\n"
+ "3.98`5*^3\n"
+ "16^^dead.beef``+4*^-3\n"
+ "0.0000000001*^10\n"
+ "35^^small*^-10\n"
+ "10000000000*^-10\n\n"
+ "// Non-examples\n"
+ "1..\n"
+ "123...\n"
+ "35^^WolframLanguage\n"
+ "16^^dead..Beef\n"
+ "16^^9fe..c3`7\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}