use strict;
my $str = '<span class="nav-next-btn nohistory FloatRight">
			 
				<span class="nav-next-btn nohistory marginRight">
					<a href="http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1" title="Go to next page">
						Next ›
					</a>
				</span>
			
			
	
			
				<a href="http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1" title="Go to last page">
					Last »
				</a>
			   		
			                                                     
		</span>';
my $regex = qr@<[^"]*class="[^"]*(?<="|\s)marginRight(?="|\s[^"]*)"[^"]*href="(?<url>([^?][^\d+]*(?<number>\d+))[^"]*)"@p;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}