Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
@
<[^"]*class="[^"]*(?<="|\s)marginRight(?="|\s[^"]*)"[^"]*href="(?<url>([^?][^\d+]*(?<number>\d+))[^"]*)"
@
g
Input 1
1
New
<span class="nav-next-btn nohistory FloatRight"> <span class="nav-next-btn nohistory marginRight"> <a href="http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1" title="Go to next page"> Next › </a> </span> <a href="http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1" title="Go to last page"> Last » </a> </span>