# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[^\"]*class=\"[^\"]*(?<=\"|\s)marginRight(?=\"|\s[^\"]*)\"[^\"]*href=\"(?<url>([^?][^\d+]*(?<number>\d+))[^\"]*)\""
test_str = ("<span class=\"nav-next-btn nohistory FloatRight\">\n"
	"			 \n"
	"				<span class=\"nav-next-btn nohistory marginRight\">\n"
	"					<a href=\"http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1\" title=\"Go to next page\">\n"
	"						Next ›\n"
	"					</a>\n"
	"				</span>\n"
	"			\n"
	"			\n"
	"	\n"
	"			\n"
	"				<a href=\"http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1\" title=\"Go to last page\">\n"
	"					Last »\n"
	"				</a>\n"
	"			   		\n"
	"			                                                     \n"
	"		</span>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.