#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\s\d(?:[\d]*\.\d+|[\d]*)\}"
Local $sString = "{ 16812}," & @CRLF & _
"{ 16812}," & @CRLF & _
"{ 16813}," & @CRLF & _
"{ 16819}," & @CRLF & _
"{ 16812}," & @CRLF & _
"{value 16812}," & @CRLF & _
"{value 16812]},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")