using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s\d(?:[\d]*\.\d+|[\d]*)\}";
string input = @"{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}