$re = '/\A(?:.*\R){15}\K\X+/m';
$str = '1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;