package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^(?:https:\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\/image\/))(.+)$`)
var str = `https://url.com/image/img.jpg
https://url.com/image/asdasdasd.jpg
`
var substitution = "https://newurl.com/$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}