using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))";
string substitution = @"SUM";
string input = @"5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}