use strict;
my $str = 'GL 5864 H598 M8-2+3
ZN 2455 B927(5.0)
LI 21900 H592
LH 42800.2004 H7
LI 99999 T454 Thomas
KI 5234 D65.2002
CB 3700 N664(3)
UQ 1000 B726 K9(7)E(3)
FH 15900 V878-2(3)';
my $regex = qr/([A-Z]{2} \d{3,6})(\.\d*)?( [A-Z]\d+)+([\.\d\-\(\)\+]*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}